#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[^"](?=(?:[^"]*?(?:["][^"]*?["][^"]*?)+$)|(?:[^"]*?$)))*|(^[^"]*["][^"]*$)"
Local $sString = " sfdgdf; gsdf;l fdg sldkjldfj kgslkdf gfd sldkjldfj fjsldk klfdsl " sldkjldfj glkdfg "sfdg fd "sfdg sdf gdsfg sdf g" skdjf ksjd fkasdj f" alskdjf laksdjf asdlk f" akdsjhf kasdk j"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")