$re = '/(?:[^"](?=(?:[^"]*?(?:["][^"]*?["][^"]*?)+$)|(?:[^"]*?$)))*|(^[^"]*["][^"]*$)/';
$str = ' sfdgdf; gsdf;l fdg sldkjldfj kgslkdf gfd sldkjldfj fjsldk klfdsl " sldkjldfj glkdfg "sfdg fd "sfdg sdf gdsfg sdf g" skdjf ksjd fkasdj f" alskdjf laksdjf asdlk f" akdsjhf kasdk j';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);