re = /(?:[^"](?=(?:[^"]*?(?:["][^"]*?["][^"]*?)+$)|(?:[^"]*?$)))*|(^[^"]*["][^"]*$)/
str = ' sfdgdf; gsdf;l fdg sldkjldfj kgslkdf gfd sldkjldfj fjsldk klfdsl " sldkjldfj glkdfg "sfdg fd "sfdg sdf gdsfg sdf g" skdjf ksjd fkasdj f" alskdjf laksdjf asdlk f" akdsjhf kasdk j'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end