import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^\"](?=(?:[^\"]*?(?:[\"][^\"]*?[\"][^\"]*?)+$)|(?:[^\"]*?$)))*|(^[^\"]*[\"][^\"]*$)";
final String string = " sfdgdf; gsdf;l fdg sldkjldfj kgslkdf gfd sldkjldfj fjsldk klfdsl \" sldkjldfj glkdfg \"sfdg fd \"sfdg sdf gdsfg sdf g\" skdjf ksjd fkasdj f\" alskdjf laksdjf asdlk f\" akdsjhf kasdk j";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}