using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^""](?=(?:[^""]*?(?:[""][^""]*?[""][^""]*?)+$)|(?:[^""]*?$)))*|(^[^""]*[""][^""]*$)";
string input = @" sfdgdf; gsdf;l fdg sldkjldfj kgslkdf gfd sldkjldfj fjsldk klfdsl "" sldkjldfj glkdfg ""sfdg fd ""sfdg sdf gdsfg sdf g"" skdjf ksjd fkasdj f"" alskdjf laksdjf asdlk f"" akdsjhf kasdk j";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}