const regex = /(?:[^"](?=(?:[^"]*?(?:["][^"]*?["][^"]*?)+$)|(?:[^"]*?$)))*|(^[^"]*["][^"]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^"](?=(?:[^"]*?(?:["][^"]*?["][^"]*?)+$)|(?:[^"]*?$)))*|(^[^"]*["][^"]*$)', 'g')
const str = ` sfdgdf; gsdf;l fdg sldkjldfj kgslkdf gfd sldkjldfj fjsldk klfdsl " sldkjldfj glkdfg "sfdg fd "sfdg sdf gdsfg sdf g" skdjf ksjd fkasdj f" alskdjf laksdjf asdlk f" akdsjhf kasdk j`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}