# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w\s]+)\s([\(\)\d-\[\]\.\\/-]+)\s(.*)/Name:\1#Phone:\2#Address\3/;t' <<< "Andy Leblanc (0123-123-12312) Seaview Av. Street no 21, East Singapore 11221"