using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\s]+)\s([\(\)\d-\[\]\.\/-]+)\s(.*)";
string substitution = @"Name:\1#Phone:\2#Address\3";
string input = @"Andy Leblanc (0123-123-12312) Seaview Av. Street no 21, East Singapore 11221";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}