import re
regex = re.compile(r"([\w\s]+)\s([\(\)\d-\[\]\.\/-]+)\s(.*)")
test_str = "Andy Leblanc (0123-123-12312) Seaview Av. Street no 21, East Singapore 11221"
subst = "Name:\\1#Phone:\\2#Address\\3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)