use strict;
my $str = 'Andy Leblanc (0123-123-12312) Seaview Av. Street no 21, East Singapore 11221';
my $regex = qr/([\w\s]+)\s([\(\)\d-\[\]\.\/-]+)\s(.*)/p;
my $subst = 'Name:\\1#Phone:\\2#Address\\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";