import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w\\s]+)\\s([\\(\\)\\d-\\[\\]\\.\\/-]+)\\s(.*)";
final String string = "Andy Leblanc (0123-123-12312) Seaview Av. Street no 21, East Singapore 11221";
final String subst = "Name:\\1#Phone:\\2#Address\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}