re = /([\w\s]+)\s([\(\)\d-\[\]\.\/-]+)\s(.*)/
str = 'Andy Leblanc (0123-123-12312) Seaview Av. Street no 21, East Singapore 11221'
subst = 'Name:\\1#Phone:\\2#Address\\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result