const regex = new RegExp('\\b([0-9]{1,2})-([a-zA-Z]+(?:\\s+[a-zA-Z]+))\\b', 'gm')
const str = `1-New Bathroom 2-New Kitchen 3-New Garden 4-Caribbean Holiday`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}