re = /\b([0-9]{1,2})-([a-zA-Z]+(?:\s+[a-zA-Z]+))\b/m
str = '1-New Bathroom 2-New Kitchen 3-New Garden 4-Caribbean Holiday'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end