import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s\\S]*(?=\\n{2,})";
final String string = "YYYY-MM-DD HH:II:SS Message Log\n"
+ " Message Log\n"
+ " Message Log\n\n"
+ "YYYY-MM-DD HH:II:SS Message Log80s]] ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}