import re
regex = re.compile(r"[\s\S]*(?=\n{2,})")
test_str = ("YYYY-MM-DD HH:II:SS Message Log\n"
" Message Log\n"
" Message Log\n\n"
"YYYY-MM-DD HH:II:SS Message Log80s]] ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")