re = /[\s\S]*(?=\n{2,})/
str = 'YYYY-MM-DD HH:II:SS Message Log
Message Log
Message Log
YYYY-MM-DD HH:II:SS Message Log80s]] '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end