using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*website.com($|\/$|\?.*|\/\?.*)";
string input = @"website.com
website.com/
http://website.com
https://website.com/
https://website.com/?utm_source=test
https://website.com/product
https://website.com/services/service1
https://website.com/blog
https://website.com/etc.etc.etc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}