re = /^.*website.com($|\/$|\?.*|\/\?.*)/m
str = 'website.com
website.com/
http://website.com
https://website.com/
https://website.com/?utm_source=test
https://website.com/product
https://website.com/services/service1
https://website.com/blog
https://website.com/etc.etc.etc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end