package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*website.com($|\/$|\?.*|\/\?.*)`)
var str = `website.com
website.com/
http://website.com
https://website.com/
https://website.com/?utm_source=test
https://website.com/product
https://website.com/services/service1
https://website.com/blog
https://website.com/etc.etc.etc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}