import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*website.com($|\\/$|\\?.*|\\/\\?.*)";
final String string = "website.com\n"
+ "website.com/\n"
+ "http://website.com\n"
+ "https://website.com/\n"
+ "https://website.com/?utm_source=test\n"
+ "https://website.com/product\n"
+ "https://website.com/services/service1\n"
+ "https://website.com/blog\n"
+ "https://website.com/etc.etc.etc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}