// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*website.com($|\/$|\?.*|\/\?.*)").unwrap();
let string = "website.com
website.com/
http://website.com
https://website.com/
https://website.com/?utm_source=test
https://website.com/product
https://website.com/services/service1
https://website.com/blog
https://website.com/etc.etc.etc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}