#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<a\s[^>]*?href="javascript:void\(0\)\;?"[^>]*?>(.*?)<\/a>"
Local $sString = "<a href="http://www.google.com">Default link</a>" & @CRLF & _
"<a href="#anchor">Anchor link</a>" & @CRLF & _
"<a href="javascript:void(0);">JS link</a>" & @CRLF & _
"<a href="javascript:void(0);" class="foo">JS link with attributes after href</a>" & @CRLF & _
"<a id="foo" href="javascript:void(0);">JS link with attributes before href</a>" & @CRLF & _
"<a id="bar" " & @CRLF & _
" href="javascript:void(0);" " & @CRLF & _
" class="foo">" & @CRLF & _
"JS link on several lines" & @CRLF & _
"</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")