$re = '/<a\s[^>]*?href="javascript:void\(0\)\;?"[^>]*?>(.*?)<\/a>/si';
$str = '<a href="http://www.google.com">Default link</a>
<a href="#anchor">Anchor link</a>
<a href="javascript:void(0);">JS link</a>
<a href="javascript:void(0);" class="foo">JS link with attributes after href</a>
<a id="foo" href="javascript:void(0);">JS link with attributes before href</a>
<a id="bar"
href="javascript:void(0);"
class="foo">
JS link on several lines
</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);