import re
regex = re.compile(r"<a\s[^>]*?href=\"javascript:void\(0\)\;?\"[^>]*?>(.*?)<\/a>", flags=re.DOTALL | re.IGNORECASE)
test_str = ("<a href=\"http://www.google.com\">Default link</a>\n"
"<a href=\"#anchor\">Anchor link</a>\n"
"<a href=\"javascript:void(0);\">JS link</a>\n"
"<a href=\"javascript:void(0);\" class=\"foo\">JS link with attributes after href</a>\n"
"<a id=\"foo\" href=\"javascript:void(0);\">JS link with attributes before href</a>\n"
"<a id=\"bar\" \n"
" href=\"javascript:void(0);\" \n"
" class=\"foo\">\n"
"JS link on several lines\n"
"</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")