const regex = /<a\s[^>]*?href="javascript:void\(0\)\;?"[^>]*?>(.*?)<\/a>/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s[^>]*?href="javascript:void\\(0\\)\\;?"[^>]*?>(.*?)<\\\/a>', 'gsi')
const str = `<a href="http://www.google.com">Default link</a>
<a href="#anchor">Anchor link</a>
<a href="javascript:void(0);">JS link</a>
<a href="javascript:void(0);" class="foo">JS link with attributes after href</a>
<a id="foo" href="javascript:void(0);">JS link with attributes before href</a>
<a id="bar"
href="javascript:void(0);"
class="foo">
JS link on several lines
</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}