use strict;
my $str = '<a href="http://www.google.com">Default link</a>
<a href="#anchor">Anchor link</a>
<a href="javascript:void(0);">JS link</a>
<a href="javascript:void(0);" class="foo">JS link with attributes after href</a>
<a id="foo" href="javascript:void(0);">JS link with attributes before href</a>
<a id="bar"
href="javascript:void(0);"
class="foo">
JS link on several lines
</a>';
my $regex = qr/<a\s[^>]*?href="javascript:void\(0\)\;?"[^>]*?>(.*?)<\/a>/sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}