import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s[^>]*?href=\"javascript:void\\(0\\)\\;?\"[^>]*?>(.*?)<\\/a>";
final String string = "<a href=\"http://www.google.com\">Default link</a>\n"
+ "<a href=\"#anchor\">Anchor link</a>\n"
+ "<a href=\"javascript:void(0);\">JS link</a>\n"
+ "<a href=\"javascript:void(0);\" class=\"foo\">JS link with attributes after href</a>\n"
+ "<a id=\"foo\" href=\"javascript:void(0);\">JS link with attributes before href</a>\n"
+ "<a id=\"bar\" \n"
+ " href=\"javascript:void(0);\" \n"
+ " class=\"foo\">\n"
+ "JS link on several lines\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}