#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(\d+|\d{1,3}(?:\,\d{3})+)?(\.\d+)?$"
Local $sString = "1234567890" & @CRLF & _
"12345678.901" & @CRLF & _
"123,456,789.01" & @CRLF & _
"123,45678.901" & @CRLF & _
"123,456,789..01" & @CRLF & _
"123,456,789." & @CRLF & _
".0123456789" & @CRLF & _
"-1234567890" & @CRLF & _
"-12345678.901" & @CRLF & _
"-123,456,789.01" & @CRLF & _
"-123,45678.901" & @CRLF & _
"123,456,789..01" & @CRLF & _
"-123,456,789." & @CRLF & _
"-.0123456789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")