import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(\\d+|\\d{1,3}(?:\\,\\d{3})+)?(\\.\\d+)?$";
final String string = "1234567890\n"
+ "12345678.901\n"
+ "123,456,789.01\n"
+ "123,45678.901\n"
+ "123,456,789..01\n"
+ "123,456,789.\n"
+ ".0123456789\n"
+ "-1234567890\n"
+ "-12345678.901\n"
+ "-123,456,789.01\n"
+ "-123,45678.901\n"
+ "123,456,789..01\n"
+ "-123,456,789.\n"
+ "-.0123456789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}