using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(\d+|\d{1,3}(?:\,\d{3})+)?(\.\d+)?$";
string input = @"1234567890
12345678.901
123,456,789.01
123,45678.901
123,456,789..01
123,456,789.
.0123456789
-1234567890
-12345678.901
-123,456,789.01
-123,45678.901
123,456,789..01
-123,456,789.
-.0123456789";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}