package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?(\d+|\d{1,3}(?:\,\d{3})+)?(\.\d+)?$`)
var str = `1234567890
12345678.901
123,456,789.01
123,45678.901
123,456,789..01
123,456,789.
.0123456789
-1234567890
-12345678.901
-123,456,789.01
-123,45678.901
123,456,789..01
-123,456,789.
-.0123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}