const regex = /^-?(\d+|\d{1,3}(?:\,\d{3})+)?(\.\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(\\d+|\\d{1,3}(?:\\,\\d{3})+)?(\\.\\d+)?$', 'gm')
const str = `1234567890
12345678.901
123,456,789.01
123,45678.901
123,456,789..01
123,456,789.
.0123456789
-1234567890
-12345678.901
-123,456,789.01
-123,45678.901
123,456,789..01
-123,456,789.
-.0123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}