#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z_]\w*(\.[a-zA-Z_]\w*)*$"
Local $sString = "Parent.Property" & @CRLF & _
"Name" & @CRLF & _
"_P.Age" & @CRLF & _
"_Parent._Name" & @CRLF & _
"p.Office_Address" & @CRLF & _
"_" & @CRLF & _
"@Bool" & @CRLF & _
"9Type" & @CRLF & _
"_Parent.@static" & @CRLF & _
"@class._" & @CRLF & _
"@pou8_9iu.@" & @CRLF & _
"@" & @CRLF & _
"_Parent.9" & @CRLF & _
"7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")