import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z_]\\w*(\\.[a-zA-Z_]\\w*)*$";
final String string = "Parent.Property\n"
+ "Name\n"
+ "_P.Age\n"
+ "_Parent._Name\n"
+ "p.Office_Address\n"
+ "_\n"
+ "@Bool\n"
+ "9Type\n"
+ "_Parent.@static\n"
+ "@class._\n"
+ "@pou8_9iu.@\n"
+ "@\n"
+ "_Parent.9\n"
+ "7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}