use strict;
my $str = 'Parent.Property
Name
_P.Age
_Parent._Name
p.Office_Address
_
@Bool
9Type
_Parent.@static
@class._
@pou8_9iu.@
@
_Parent.9
7';
my $regex = qr/^[a-zA-Z_]\w*(\.[a-zA-Z_]\w*)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}