// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z_]\w*(\.[a-zA-Z_]\w*)*$").unwrap();
let string = "Parent.Property
Name
_P.Age
_Parent._Name
p.Office_Address
_
@Bool
9Type
_Parent.@static
@class._
@pou8_9iu.@
@
_Parent.9
7";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}