re = /^[a-zA-Z_]\w*(\.[a-zA-Z_]\w*)*$/m
str = 'Parent.Property
Name
_P.Age
_Parent._Name
p.Office_Address
_
@Bool
9Type
_Parent.@static
@class._
@pou8_9iu.@
@
_Parent.9
7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end