import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:'([^'\\\\]*(?:\\\\.[^'\\\\]*)*)'|([^,]+))";
final String string = "'ei-1395529080',0,0,1,1,'Name','email@domain.com','Sentence with \\'escaped apostrophes\\', which \\'should\\' be on one line!','no','','','yes','6.50',NULL";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}