re = /(?:'([^'\\]*(?:\\.[^'\\]*)*)'|([^,]+))/
str = '\'ei-1395529080\',0,0,1,1,\'Name\',\'email@domain.com\',\'Sentence with \\\'escaped apostrophes\\\', which \\\'should\\\' be on one line!\',\'no\',\'\',\'\',\'yes\',\'6.50\',NULL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end