// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:'([^'\\]*(?:\\.[^'\\]*)*)'|([^,]+))").unwrap();
let string = "'ei-1395529080',0,0,1,1,'Name','email@domain.com','Sentence with \\'escaped apostrophes\\', which \\'should\\' be on one line!','no','','','yes','6.50',NULL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}