const regex = /(?:'([^'\\]*(?:\\.[^'\\]*)*)'|([^,]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\'|([^,]+))', 'g')
const str = `'ei-1395529080',0,0,1,1,'Name','email@domain.com','Sentence with \\'escaped apostrophes\\', which \\'should\\' be on one line!','no','','','yes','6.50',NULL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}