$re = '/(?:\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\'|([^,]+))/';
$str = '\'ei-1395529080\',0,0,1,1,\'Name\',\'email@domain.com\',\'Sentence with \\\'escaped apostrophes\\\', which \\\'should\\\' be on one line!\',\'no\',\'\',\'\',\'yes\',\'6.50\',NULL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);