package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%a+`)
var str = `HTTP/1.1 200 OK
Cache-Control: private
Content-Type: text/plain; charset=utf-8
X-AspNet-Version: 4.0.30319
Date: Sat, 13 Feb 2016 19:33:11 GMT
Content-Length: 6
|on||30|`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}