# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"%a+"
test_str = ("HTTP/1.1 200 OK\n"
"Cache-Control: private\n"
"Content-Type: text/plain; charset=utf-8\n"
"X-AspNet-Version: 4.0.30319\n"
"Date: Sat, 13 Feb 2016 19:33:11 GMT\n"
"Content-Length: 6\n\n"
"|on||30|")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.