const regex = /%a+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%a+', '')
const str = `HTTP/1.1 200 OK
Cache-Control: private
Content-Type: text/plain; charset=utf-8
X-AspNet-Version: 4.0.30319
Date: Sat, 13 Feb 2016 19:33:11 GMT
Content-Length: 6
|on||30|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}