#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z0-9]+(['_-]?[A-Za-z0-9]+)?"
Local $sString = "Hello, world!" & @CRLF & _
"Aren't you clever?" & @CRLF & _
"'Later', she said." & @CRLF & _
"'Maybe 5 o'clock?'" & @CRLF & _
"In the year 2017 ..." & @CRLF & _
"G2g, cya l8r" & @CRLF & _
"hello_world.h" & @CRLF & _
"Hermione's time-turner." & @CRLF & _
"Good mor~+%g." & @CRLF & _
"Hi' Testing_ Bye-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")