package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z0-9]+(['_-]?[A-Za-z0-9]+)?`)
var str = `Hello, world!
Aren't you clever?
'Later', she said.
'Maybe 5 o'clock?'
In the year 2017 ...
G2g, cya l8r
hello_world.h
Hermione's time-turner.
Good mor~+%g.
Hi' Testing_ Bye-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}