$re = '/[A-Za-z0-9]+([\'_-]?[A-Za-z0-9]+)?/m';
$str = 'Hello, world!
Aren\'t you clever?
\'Later\', she said.
\'Maybe 5 o\'clock?\'
In the year 2017 ...
G2g, cya l8r
hello_world.h
Hermione\'s time-turner.
Good mor~+%g.
Hi\' Testing_ Bye-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);