// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z0-9]+(['_-]?[A-Za-z0-9]+)?").unwrap();
let string = "Hello, world!
Aren't you clever?
'Later', she said.
'Maybe 5 o'clock?'
In the year 2017 ...
G2g, cya l8r
hello_world.h
Hermione's time-turner.
Good mor~+%g.
Hi' Testing_ Bye-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}